EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#1129 - Probleme mit Mehrmonitorsystem

Gehört zu Projekt: ac'tivAid
Angelegt Anonymer Reporter - Montag, 12. November 2007 - 12:37
Zuletzt bearbeitet von Wolfgang Reszel (Tekl) - Montag, 19. November 2007 - 13:13
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → ScreenShots
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP2
Schweregrad Hoch
Priorität Normal
Betrifft Version 1.2.1
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

Hallo,

ich habe ein System mit zwei Monitoren an einer Matrox
ist frisch installiert, alle Einstellungen auf Default außer das ich nicht in eine Datei speichere.

Der Bereich der darstellt was ich gerade markieren möchte, wird horizontal verschoben dargestellt. Es werden nicht immer beide Monitore abgedunkelt.

Das ganze reagiert sehr träge.

Kann man das Grad des abdunkeln beeinflußbar setzen? Mir ist das zu dunkel.

Sonst ein nettes Teil. Weiter so!

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Montag, 19. November 2007 - 13:13
Grund für Schließung:  korrigiert
Zusätzlicher Kommentar zur Schließung:  Kommt mit der nächsten Beta
Kommentar von Holger (Holger) - Dienstag, 13. November 2007 - 20:44

Das mit der trägen Reaktion kann ich bestätigen, aber außerdem noch die genannten Probleme aus #1133

(Windows 2000, zwei Monitore, Portable 1.2.1)

Kommentar von Lutz Scheffler (lusc86) - Donnerstag, 15. November 2007 - 08:06

Zunächst meine Entschuldigung für den anonymen thread, ich war nicht in der Lage mich anzumelden.

Ich habe das Problem eingegrenzt.

Mein System hat den primären Monitor rechts, nicht wie MS default links. Das gibt negative Koordinaten für den sekundären Screen. Ich habe nicht getestet was passiert wenn die Monitore übereinander oder verschoben sind, aber ich denke das Problem ist klar.

Kommentar von Michael (Michael) - Donnerstag, 15. November 2007 - 08:13

Multimonitor mit negativen
Stand: der Rahmen wird an der richtigen Stelle angezeigt, die weiße Fläche ist an der falschen stelle

eine aktuellere Version von ScreenShots als die von der beta bitte über die Posts in  FS#1133  beziehen.

Kommentar von Lutz Scheffler (lusc86) - Donnerstag, 15. November 2007 - 09:42

O.K., dann folge ich  FS#1133  für das
wir diesen Thread schließen, dann mache ich einen neuen für den Grad der Abdunklung?

Kommentar von Michael (Michael) - Donnerstag, 15. November 2007 - 10:40

In der letzten Version von  FS#1133  gibt es schon eine Einstellung für den Grad der Abdunklung. Sie muss allerdings noch per Hand in die ini eingetragen
Variable lautet DimTransparency

Kommentar von Lutz Scheffler (lusc86) - Donnerstag, 15. November 2007 - 11:20

Ja, so ist das hübsch. Man könnte es natürlich auch but einfärben aber das ist letzlich Spielerei.

Kommentar von Holger (Holger) - Donnerstag, 15. November 2007 - 13:13

Ich habe die neue Version getestet: die Interaktive Ausschnittswahl funktioniert jetzt. (meine zwei Monitore sind richtig rum
ich den Screenshot in die Zwischenablage kopieren lasse funkioniert es, bis auf "Aktives Fenster" hier wird eine schwarze Grafik
kann ich den Screenshot nicht abspeichern: "in Datei speichern" funktioniert nicht, es wird keine Fehlermeldung erzeugt, aber auch keine Grafik abgespreichert. Ich kann jetzt die Zwischenablage in z.B. iView einfügen und dann speichern, aber das ist nicht die gewünschte Funktion ;-)

Kommentar von Michael (Michael) - Donnerstag, 15. November 2007 - 15:39

1. Sind bei "Aktives Fenster" alle Programme, oder nur bestimmte Programme betroffen? Manche Programme nutzen spezielle Anzeigeoptionen (so lassen sich zum Beispiel Videos meist gar nicht fotografieren).

2. Existiert der Ordner, der bei "Zielordner:" angegeben ist? Und wenn ja, hat der aktuelle Nutzer Schreibrechte darauf?

Kommentar von Holger (Holger) - Donnerstag, 15. November 2007 - 21:12

zu 1. ich habe es schon bei ein paar Programmenfenstern ausprobiert - frag mich aber nicht wieviele verschiedene Programme es waren.... - teste ich morgen nochmal

zu 2. C:\ ist vorhanden ;-) und hab dort natürlich Schreibrechte. Ich habe es auch mit c:\temp probiert, dürfte also nicht das Problem sein.

Mir ist jetzt noch ein Unterschied zum anderen Rechner aufgefallen: mit der Option "Zielordner nach Screenshot öffnen" startet zuhause der Explorer mit dem Verzeichnis in der der Screenshot liegt, im Büro kommt dabei eine Fehlermeldung dass die Datei (ScreenshotDateiname) nicht geöffnet werden kann (genaue Fehlermeldung kann ich morgen liefern).

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 16. November 2007 - 08:41

Zu Mehrmonitor-Systemen habe ich mal einen Fix angehängt. Bitte mal testen. Ich bin davon ausgegangen, dass die obere linke Ecke des primären Bildschirms immer die Koordinaten x0 y0 hat. Weiß jemand, ob das so korrekt ist?

Wie lautet denn der Dateiname? Evtl. werden da noch nicht alle illegale Zeichen rausgefiltert.

Kommentar von Holger (Holger) - Freitag, 16. November 2007 - 09:18

zu 1. habe verschiedene Programme ausprobiert: Word, Explorer, IE, Wordpad... immer nur eine schwarze Grafik in Fenstergröße, egal ob das Fenster maximiert war oder nicht. "Arbeitsbereich des aktuellen Fensters" funktioniert.

zu 2. Bei der Auswahl der Option "Zielordner nach Screenshot öffnen" kommt folgende Fehlermeldung: Der Pfad "C:\test\Screenshot Dokument1 - Microsoft Word.jpg" ist nicht vorhanden oder verweist auf kein Verzeichnis. Gleicher Fehler bei verschiedenen
Verzeichnis hatte ich vorher über "Ordner wählen" "Neuer Ordner" angelegt.

Gleiche Fehler auch mit der neuen Version.

Links oben beim Prim. Monitor ist x0y0, egal welchen Monitor man zum Prim. macht. Nur: ist der rechte Monitor der Prim. gibts auf dem linken Monito negative x/y Koordinaten.

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 16. November 2007 - 09:28

zu 1.: nutzt irgend welche speziellen Skins? Was passiert wenn du den Haken oben links aktivierst oder deaktivierst?

zu 2.: Die Meldung besagt nur, dass die Datei nicht gefunden wurde, am Ordner liegt's wohl weniger. Die Dateien kannst du mit gleichem Namen aber manuell anlegen, oder?

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 16. November 2007 - 09:35

Holger, du sprichst von Win 2000, hat das bei dir evtl. nicht die DLL gdiplus.dll? Ohne die geht's nicht.

Kommentar von Holger (Holger) - Freitag, 16. November 2007 - 09:44

zu 1. nein, keine Skins (geht sowas bei Win2000? ist Firmenrechner mit eingeschränkten Rechten. darum auch die
ich den Haken weg mache, wird ein Bild erzeugt, mit Haken schwarze Grafik.

zu 2. ich kann in dem Verzeichnis eine Datei mit dem gleichen Namen erzeugen.

Kommentar von Holger (Holger) - Freitag, 16. November 2007 - 09:50

im System32 Verzeichnis hätte ich eine gdi32.dll anzubieten ;-) gdiplus.dll wird auf meinem Rechner nicht
komm ich denn zu der DLL?

Bei den Sachen die funktionieren, ist es egal ob ich meinen primären Monitor rechts oder links habe.

Kommentar von Lutz Scheffler (lusc86) - Freitag, 16. November 2007 - 09:53

Bei meiner aktuellen Monitorkonfiguration funktioniert es auf beiden Monitoren.

Ich werde über Mittag die Anordnung nochmal etws würfeln und sehen was dann passiert.


Kommentar von Lutz Scheffler (lusc86) - Freitag, 16. November 2007 - 11:06

Also ich habe den Monitor jetz an alle unmögliche Ecken geschoben es es wird der richtige Bereich markiert. Einmal, nicht reproduzierbar, war der sekundäre Monitor nicht eingefärbt / abgedunkelt.


Kommentar von Wolfgang Reszel (Tekl) - Freitag, 16. November 2007 - 11:52

Anbei mal eine weitere Überarbeitung.

@Holger: Die schwarzen Fenster kommen von der "Unterstützung für verdeckte Fenster", welche du mit der angehängten Version generell abschalten kannst. Zudem weist die Version auf das DLL-Problem hin.

Kommentar von Holger (Holger) - Freitag, 16. November 2007 - 13:01

Danke für die neue Version und den Hinweistext wenn die DLL nicht vorhanden
DLL funktioniert jetzt auch das speichern.

Die Funktion mit dem verdeckten Fenster habe ich über die Optionen ausgeschaltet, ist ja nix dramatisches, wenn alles andere
den Optionen ist ein Tippfehler: Bildschir_foto direkt nach Loslassen... da fehlt ein m

Somit funktioniert jetzt alles - vielen Dank für die schnelle Hilfe!

Schönen

Lade...