EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#1144 - Screenshots - Clibboard nicht gefüllt abfangbar?

Gehört zu Projekt: ac'tivAid
Angelegt eric (ewerybody) - Freitag, 16. November 2007 - 15:09
Zuletzt bearbeitet von Wolfgang Reszel (Tekl) - Montag, 10. Dezember 2007 - 16:09
Aufgabentyp Fehlerbericht
Kategorie ac'tivAid allgemein
Status Warten auf Antwort
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Alle
Schweregrad Niedrig
Priorität Normal
Betrifft Version zukünftige Version
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 0%
Stimmen 0
Versteckt Nein

Beschreibung

Kennt jemand das Problem? Man drückt tausendmal auf die scheiss Druck Taste (auch ohne ac’tivAids’ ScreenShots) Und im PS kommt partout nix an!!?

Ich hab das Gefühlt das passiert auch MIT ScreenShots! Ich meine wenn Windows das füllen des Clipboards mit großen Daten irgendwie blockiert, ja dann gehts halt auch nicht mit Autohotkey.


könnte doch bevor der Vorgang vorbei ist, wenn im Clipboard abgelegt werden soll checken ob das Clipboard auch dementsprechend gefüllt wurde oder? Wenns nicht geklappt hat, dann MsgBox: und anbieten als File zu speichern. Was haltet ihr davon?

Kann man vielleicht schon vorher rausfinden ob das Clipboard überhaupt gerade willich
kann das vielleicht auch überhaupt keiner nachvollziehen was ich hier rede? :]

Diese Aufgabe ist abhängig von

Kommentar von Wolfgang Reszel (Tekl) - Montag, 19. November 2007 - 09:01

Ich kann das nicht nachvollziehen. Wenn die Zwischenablage nicht gefüllt wird, kann das auch ac'tivAid nicht mitbekommen. Was zeigt dir denn clipbrd.exe an? Bei einigen Versionen von Photoshop gab's mal die Einschränkung, dass es ein veränderte Zwischenablage erst bemerkt hat, wenn man kurz ein anderes Programm aktiviert und dann wieder Photoshop.

Kommentar von eric (ewerybody) - Montag, 19. November 2007 - 10:50

clipbrd.exe? wasn
kieke an! Das is nen windows tool? kannt ich noch gar nich :]

Ja muss ich ma kieken wenn wieder son fall kommt. Aber da das gerade auch nen Kollege berichtet hatte dachte ich das is der Beweis, daß das auch anderen so gehen kann. Klar ist: Das taucht nur manchmal auf. Wenn dann aber hartnäckig! Ich werd ma drauf achten.

Kommentar von eric (ewerybody) - Mittwoch, 09. Januar 2008 - 22:38

schaise!!!! Nu hab ich gerade echt den Fall, daß es nicht
was is? Hier auf dem Laptop kanner "clipbrd.exe" nich finden! AHHRGG!!!

hmmm.. na ich hab ja noch das als Datei ablegen und Dateiname im
wenn man das Graue Häkchen benutzt, dann steht der Dateiname nicht im Clipboard. Soll das so sein?

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 10. Januar 2008 - 05:52

Der Graue haken legt eine Datei an und den ScreenShot in die Zwischenablage, nicht den Dateinamen. Du musst den normalen Haken nehmen und die Option in weitere Optionen aktivieren.

Kommentar von eric (ewerybody) - Donnerstag, 10. Januar 2008 - 08:25

Det wees ick schon allet :]

Aber wieso legter denn den Dateinamen nicht ins Clipboard? Es wird doch auch ne Datei erstellt bei grau.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 10. Januar 2008 - 09:46

Weil schon der ScreenShot im Clipboard ist.

Kommentar von eric (ewerybody) - Donnerstag, 10. Januar 2008 - 11:21

*räusper* *klatsch*
das is natürlich nen
mir in diesem Fall nicht in den Sinn gekommen, weils ja nicht funktioniert hat
hab dann in PS immer das letzte Bild im Clipboard, das ich mit PS kopiert hatte.

Öhm.. ja pardon. Aber zurück auch zum Thema:

kann man nicht im Script
Clipboard zu
Clipboard mit der alten Variable
wenn ungleich Meldung machen

Klar, in den meisten Fällen wurde das einfach durchrauschen, aber in meinem Fall... verdammt, hätt ich auch ma selber prüfen können.

Kommentar von Michael (Michael) - Dienstag, 19. Februar 2008 - 07:20

Wenn im Clipboard immer das letzte PS Bild ist, hört sich das für mich so an, als ob PS eine eigene Zwischenablage hat, die dann aktiviert wird, wenn man in PS was kopiert. Sowas ähnliches gibt auch bei MS Office. Vielleicht klappt die Synchronisation der PS Zwischenablage mit der Win Zwischenablage
wird eingefügt, wenn man den Inhalt der Zwischenablage in einem anderen Grafikprogramm (Paint, IrfanView, ...) einfügt? Denn das ist dann ziemlich sicher Inhalt der Win Zwischenablage und nicht der einer eventuell vorhandenen PS Zwischenablage.

Kommentar von eric (ewerybody) - Dienstag, 19. Februar 2008 - 09:13

hmm das kligt in der Tat nach einer interessanten Theorie. Aber eigentlich ist doch Clipboard clipboard
werds ma einfach ausprobieren...

Nee. Also so aufn schnellen Test: Die PS-Zwischenablage "verstopft" die Win Zwischenablage nicht. Ich kann sie beliebig mit Screenshots überschreiben und sie dann auch in PS pasten. Und ich kann auch Material aus PS irgendwo anders pasten (dabei geht aber in der Regel Alphatransparenz flöten). Das is nicht der Bug :/

Na ich werd ma warten bis es wiedermal passiert ;]

Lade...