EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#1253 - Applauncher: Crash beim Aufruf von "Ausführen als"

Gehört zu Projekt: ac'tivAid
Angelegt Klaus (CaptainCrunch) - Dienstag, 08. Januar 2008 - 23:56
Zuletzt bearbeitet von Wolfgang Reszel (Tekl) - Montag, 21. Januar 2008 - 13:05
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → AppLauncher
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP1
Schweregrad Hoch
Priorität Normal
Betrifft Version 1.2.2 beta120
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 1
Versteckt Nein

Beschreibung

Wenn ich in AppLauncher für einen Eintrag “Ausführen als” auswähle, also per Kontextmenü oder Taste+Klick (btw, was ist eigentlich der Unterschied zwischen Alt+Ausführen und Strg+Alt+Ausführen ? Wird beides erwähnt.) einen Eintrag starten will crasht AutoHotkey. Manchmal kommt noch der Dialog zum Auswählen des Benutzers und es crasht erst beim Klick auf OK oder Abbrechen. Manchmal wird das Programm dann gestartet (natürlich nur bei OK), manchmal
mann “Computer und Daten ...schützen” deaktiviert (aktueller Benutzer) startet das Programm und der Crash verschiebt sich auf den nächsten Aufruf.

Im Anhang die Crash-Meldung, anschließend gibts noch einen Speicherschutzfehler, den hab ich mir mal gespart.

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Montag, 21. Januar 2008 - 13:05
Grund für Schließung:  wird nicht behoben
Zusätzlicher Kommentar zur Schließung:  Du Ursache konnte nicht geklärt werden und es scheint sich um einen Einzelfall zu handeln.
Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 09. Januar 2008 - 04:54

Ist das erst seit neustem so (seit welcher Version)? Was meinst du mit "Computer und Daten ...schützen". AppLauncher nutzt für Ausführen als die Funktion ShellExecuteA von Shell32.dll gut möglich, dass sie unter SP1 noch fehlerhaft ist. Leider sind bei mir alle verfügbaren XPs schon auf SP2.

Anbei mal ein überarbeitete Version, welche im Debug-Modus etwas mehr Informationen ausgibt.

Kommentar von Michael (Michael) - Mittwoch, 09. Januar 2008 - 12:31

Bei mir klappt immer der erste Aufruf mit Alt+Enter. Wenn ich diesen abbreche und anschließend direkt wieder starte, stürzt Autohotkey ab, bevor folgende Zeile im DebugView erscheint.

[2616] ac'tivAid_AppLauncher.ahk   1329: [APPLAUNCHER] RunAs: C:\[...].lnk ... in: C:\[...]

Im Anhang der Crashdump, Passwort ist meine Mailadresse.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 09. Januar 2008 - 13:33

Anbei ein auskunftsfreudigere Version (DbgView.exe)

Kommentar von Klaus (CaptainCrunch) - Mittwoch, 09. Januar 2008 - 14:58

Ich hatte diese Funktion bisher nicht ausprobiert, also keine Ahnung ob das früher schon so gewesen
und Daten ...schützen", damit meine ich die im angehängten Bild markierte Checkbox. Einen Fehler in der ShellExecute halte ich für unwahrscheinlich, ich könnte es aber auf einem XP mit SP2 probieren falls das was hilft.

Bei der Debug-Version stürzt DbgView ab falls es bereits läuft wenn activaid gestartet wird. Soll ich dafür eine extra Aufgabe aufmachen?

Wenn ich also activaid und DbgView laufen habe und dann den o.g. Fehler reproduziere bekomme ich überhaupt keine Debug-Meldungen. Nur eine unhandled exception und einen Speicherschutzfehler von Autohotkey.

Kommentar von Michael (Michael) - Mittwoch, 09. Januar 2008 - 15:00

Wir haben das Problem schon näher lokalisieren können. Vielen Dank für die Hilfe, wir arbeiten an einer
wir weitere Tests brauchen melden wir uns.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 09. Januar 2008 - 19:58

In der neuen Beta-Version gibt es eine "Weitere Option", wo man eine alternative Methode für RunAs aktivieren kann. Bitte mal testen, ob das was bringt.

Kommentar von Michael (Michael) - Mittwoch, 09. Januar 2008 - 20:04

Bei mir klappt es damit.

Kommentar von Klaus (CaptainCrunch) - Mittwoch, 09. Januar 2008 - 23:48

Mit der Beta48 mit alternativer Methode verhält es sich so:

Wählt man "Aktueller Benutzer" und "Computer und Daten schützen" bekommt man die angehängte Meldung und die Meldung von Activaid dass die Anwendung nicht gestartet werden konnte. Der Eintrag ist dann aus der History verschwunden.

Wählt man einen anderen Benutzer oder den aktuellen aber ohne "Computer schützen" bekommt man die selbe "Fehler in Anwendung"-Meldung und die Meldung von Activaid dass die Anwendung nicht gestartet werden konnte, die Anwendung startet aber.

Wählt man Abbrechen bekommt man die selbe "Fehler in Anwendung"-Meldung und die Meldung von Activaid dass die Anwendung nicht gestartet werden konnte.

In keinem Fall stürzt Activaid ab. (Obwohl doch Autohotkey.exe beendet wird ?!).

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 10. Januar 2008 - 06:11

Bitte füge mal in library/RunAsHelper.ahk unterhalb von ShellExecResult :=
Zeile:

msgbox, %ShellExecResult%

ein.

Welche Nummern werden dir dann bei all deinen Fällen angezeigt.

Kommentar von Klaus (CaptainCrunch) - Donnerstag, 10. Januar 2008 - 13:31

Abbrechen →
1 von meinem letzten Kommentar →
2 → 42

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 10. Januar 2008 - 17:10

Ok, die Fehlermeldung kann ich nicht verhindern, liegt wohl irgendwie an deinem System, die Sprechblase sollte aber nicht mehr erscheinen.

Kommentar von Klaus (CaptainCrunch) - Donnerstag, 10. Januar 2008 - 19:31

In Beta 50? Doch, unverändert.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 10. Januar 2008 - 21:38

Wann kommt die Sprechblase? Bei allen 3 Fällen?

Kommentar von Klaus (CaptainCrunch) - Freitag, 11. Januar 2008 - 14:39

ja

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 11. Januar 2008 - 16:39

Auch beim Abbrechen? Kann ja eigentlich nicht sein, wenn der Wert 5 ist, wird die Sprechblase übersprungen.

Suche mal in ac'tivAid_AppLauncher.ahk nach den beiden Zeilen mit RunAsHelper.ahk und füge jeweils darunter diese Zeile ein:

MsgBox, %ErrorLevel%
Kommentar von Klaus (CaptainCrunch) - Freitag, 11. Januar 2008 - 16:51

Ja, auch beim
ist immer -1073741819

Kommentar von Wolfgang Reszel (Tekl) - Montag, 14. Januar 2008 - 08:47

Und wenn du ErrorLevel durch al_DllError ersetzt, welche Nummer bekommst du da?

Kommentar von Klaus (CaptainCrunch) - Montag, 14. Januar 2008 - 13:44

Dann ist der Meldungstext leer.

Kommentar von Wolfgang Reszel (Tekl) - Dienstag, 15. Januar 2008 - 10:44

Ich habe die aktuelle Beta nun angepasst. Gegen die Absturzmeldung kann ich aber nichts machen, die kommt von Windows.

Kommentar von Klaus (CaptainCrunch) - Dienstag, 15. Januar 2008 - 13:49

OK, Danke.

Lade...