EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#1337 - Cursor springt an den Anfang der Notiz

Gehört zu Projekt: ac'tivAid
Angelegt Lars C. Bernstein (lcb) - Mittwoch, 05. März 2008 - 14:41
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → QuickNote
Status Zugeteilt
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP2
Schweregrad Hoch
Priorität Normal
Betrifft Version 1.2.2 beta120
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 0%
Stimmen 3
Versteckt Nein

Beschreibung

Beim Editieren eines Texts in QuickNote springt der Cursor nicht reproduzierbar, aber oft (alle par Wörter) an den Anfang der Notiz, so als ob Strg-Pos1 gedrückt worden wäre. Das Phänomen tritt bei der Eingabe von “normalem” Text (alphanumerische Zeichen, keine Sondertasten) auf.

Diese Aufgabe ist abhängig von

Kommentar von Dirk Schwarzmann (RobOtter) - Donnerstag, 06. März 2008 - 07:25

Jetzt wo Du es sagst... Ich beobachte das Phänomen auch schon seit einigen Beta-Versionen. Es tritt immer nur sporadisch auf und lässt sich keiner Regel zuordnen. Es ist lästig, aber nicht schlimm - immerhin gehen keine Daten verloren.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 26. März 2008 - 21:20

Habt ihr evtl. besonders viel Text drin? Schafft das Löschen der Undo-Datei kurzfristig Abhilfe? Ich kann's leider nicht nachvollziehen.

Kommentar von Dirk Schwarzmann (RobOtter) - Donnerstag, 27. März 2008 - 08:20

Nö, nicht besonders viel - 1-2kb
beobachte allerdings seit einiger Zeit das sehr unangenehme Verhalten, dass der Rechner manchmal glaubt, es sei noch die Strg oder Alt gedrückt. Dies bezieht sich allerdings nicht (nur) auf QuickNote, sondern auf jedes Programm. Das führt dann zu sehr verwirrenden Aktionen im jeweiligen Programm und ich muss dann erstmal alle Modifier-Tasten drücken, um aus dem Modus wieder raus zu
glaube, dass diese beiden Verhaltensweisen irgendwie zusammen hängen und vielleicht durch eine andere Erweiterung ausgelöst werden, bis jetzt kann ich aber nicht sagen welche. Heiße Kandidaten wären sicherlich HotStrings und UserHotkeys, aber wenn ich die für einen Tag testweise abschalte, wird ja mein System unbenutzbar ;-)

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 27. März 2008 - 08:22

Der heißeste Kandidat ist eigentlich ComfortDrag. Ich habe solche Probleme allerdings schon gelegentlich vor ac'tivAid gehabt und selbst am Mac passiert mir das manchmal. Bei ac'tivAid passiert das leider häufiger und ich weiß noch nicht genau warum. Besonders wenn der Rechner ausgelastet ist passiert mir das.

Kommentar von Ingo Freitag (IFreitag) - Samstag, 29. März 2008 - 09:59

Ich kenne das Problem auch. Allerdings habe ich ComfortDrag nicht aktiviert, so dass es zumindest nicht alleine am dem Plugin liegen
verwende ich UserHotkeys und auch CharacterAid (was ja auch immer auf die Tasten 'schaut').

Wobei sich das Phänomen bei mir mehr oder weniger darauf beschränkt, dass QuickNote STRG-L nicht die Linie zieht, sondern einfach an den Beginn des Dokuments springt (siehe
'Hängen' von Umschalttasten (STRG, SHIFT, ALT) dagegen passiert auch ab und an
Ahnung, ob zwischen den Symptomen ein Zusammenhang besteht.

Kommentar von J. Schneider (js) - Montag, 26. Mai 2008 - 08:00

Ich benutze kein ComfortDrag und habe auch keine Problem mit STRG- oder ALT-Kombinationen, aber den spontanen Sprung an den Dateianfang kann ich bestätigen (hatte ich hier auch schon mal am 19.02.08
glaubte ich eine Erhöhung der Häufigkeit mit der Länge einer Zeile zu erkennen, aber inzwischen passiert es auch nach dem 2. Buchstaben.

Kommentar von Wolfgang Reszel (Tekl) - Montag, 26. Mai 2008 - 09:24

Ich kann das leider überhaupt nicht nachvollziehen. Vielleicht schickt mir noch mal jemand sein Settings-Verzeichnis.

Kommentar von Wolfgang Reszel (Tekl) - Montag, 26. Mai 2008 - 10:26

Danke für die Datei, allerdings konnte ich es auch damit nicht nachvollziehen. Wie ich sehe, liegt die Notizdatei bei dir auf einem Netzlaufwerk. Hängt es vielleicht damit zusammen? Was passiert, wenn du die Datei mal lokal ablegst oder einen Laufwerksbuchstaben verwendest?

Kommentar von Tom Krumpschmid (mitom2) - Montag, 26. Mai 2008 - 17:38

damit hängt es nicht zusammen. bei mir sind die QuickNote-dateien im ac'tivAid-verzeichnis und es passiert ebenso.

könnte man bis zum finden des fehlers ein akkustisches signal einbauen, das einen kurzen ton ausgibt, wenn in Quicknote Strg+Pos1 gedrückt wird? so könnten wir

a) herausfinden , ob wirklich diese taste im hintergrund ausgeführt
falls dem so ist, das schreiben am fehlerhaften ort sofort unterbrechen.

CU TOM

Kommentar von Wolfgang Reszel (Tekl) - Montag, 26. Mai 2008 - 21:47

Ich vermute der Fehler passiert in der Unterroutine qn1_tim_SaveChanges:

Bitte mal direkt darunter ein Return einfügen und ac'tivAid neu laden.

Anbei auch mal eine Version, die jede erkannte Sondertaste in DebugView anzeigt (siehe FAQ).

Kommentar von J. Schneider (js) - Dienstag, 27. Mai 2008 - 12:22

Ich steh 'grad auf dem Schlauch... Soll ich unter der Routine oder unter der Zeile ein ein CR+LF einfügen? Und warum?! Die Zeilenenden sehen sowohl in Deiner Version, als auch in der vorhandenen sehr schön aus (also CR und LF am Ende jeder Zeile), die Subroutine endet mit "Return"...

Kommentar von Wolfgang Reszel (Tekl) - Dienstag, 27. Mai 2008 - 12:35

Nein ich meine den Befehl 'Return'. Dadurch, dass du ihn da hinschreibst, wird die Subroutine sozusagen deaktiviert. Ich vermute das diese Routine das Problem auslöst, da sie fast nach jedem Buchstaben ausgeführt wird. Falls du damit das Problem beseitigen kannst, weiß ich zumindest wo ich suchen muss. Ich vermute, es liegt an der Funktion GetScrollInfo() innerhalb der Subroutine.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 05. Juni 2008 - 15:44

Ich hoffe mit der neuen Beta ist das Problem behoben.

Kommentar von michael (dehner) - Montag, 26. Juli 2010 - 07:36

Gibt es hierzu inzwischen eine Lösung oder weitere
Problem tritt bei mir reproduzierbar
überwiegend "hotstrings" (ca. 30) und würde einen Zusammenhang nicht ausschließen.

Habe die v1.2.1

Kommentar von Michael H. (luckyjoker) - Dienstag, 28. Februar 2012 - 21:03

Das genannte Problem tritt bei mir mit Hotstrings dann auf, wenn ich %%{Left} schreibe.

Ergebnis ist ein markiertes zweites %.

Vlt. hilfts.

Ich habs aufgegeben. Mein Settings-VZ kann ich wg. den dort gespeicherten PWs nicht rausrücken.

Lade...