EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#1691 - Inhalt manchmal unvollständig

Gehört zu Projekt: ac'tivAid
Angelegt Andrusch (Andrusch) - Donnerstag, 08. April 2010 - 04:57
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → ScreenShots
Status Zugeteilt
Zuständig Michael (Michael)
Betriebssystem Windows XP SP3
Schweregrad Mittel
Priorität Normal
Betrifft Version 1.3.2 beta1
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 0%
Stimmen 0
Versteckt Nein

Beschreibung

Hin und wieder sind die Screenshot-Bilder unvollständig. Vorrangig Listen scheinen von diesem Problem betroffen zu sein (siehe Anhang).

Das Problem tritt im Zusammenhang mit folgender Option
Auswahl beschleunigen (Transparenz komplett deaktivieren)

Wird die Option deaktiviert, dann tritt das Problem nicht auf.

Version: 1.3.2 dev19

Diese Aufgabe ist abhängig von

Kommentar von Rico Niemand (Ricolein) - Mittwoch, 20. Oktober 2010 - 12:33


hab den Eindruck dass Screenshots manchmal einfach zu schnell agiert. Ist das Problem noch vorhanden wenn du '4 sec warten'
Rico

Kommentar von Andrusch (Andrusch) - Montag, 25. Oktober 2010 - 09:20

Stimmt, mit der 4-Sekunden-Verzögerung ist immer alles da.

Das Entfernen des "Screenshot-Rahmens" scheint manchmal noch nicht vollständig abgeschlossen zu sein. Folgende Erkenntnisse habe ich bei weiteren Tests gewonnen:

  • Sowohl die Desktop-Verknüpfungen als auch die aktive Anwendung werden beim Entfernen des Screenshot-Rahmens "aufgefrischt".
  • Die Desktopsymbole verschwinden kurz und tauchen danach wieder auf.
  • Das aktive Fenster wird komplett "geleert" und neu gezeichnet.
  • Es sind nicht nur die oben beschriebenen Listen betrofft (hier ist offensichtlich bei langen Listen nur einfach mehr Zeit zum Auffrischen notwendig, deshalb waren diese bei mir vorrangig unvollständig), sondern auch andere Fensterelemente (Rahmen, Labels, usw.)
  • Auch die kurz verschwindenden Desktopsymbole sind manchmal nicht alle im Screenshot sichtbar.
Kommentar von Rico Niemand (Ricolein) - Mittwoch, 22. Dezember 2010 - 08:36

Interessant. Ich konnte feststellen dass das Problem zu hause auf meinem Rechner (SixCore & schnelle GraKa) nie auftritt egal wie belastet der Rechner ist. Auf meinem Rechner auf Arbeit tritt es gern auf wenn Excel im Hintergrund intensive berechnungen durchführt und so beide Prozessoren voll auslastet. Ich sehe folgende zwei
Einbau einer Logik die den Screenshot erst schießt wenn der Bildschirm komplett aufgefrischt ist

 oder

- eine zusätzliche Option '1 sec warten' (dürfte schnell & einfach
machts? (oder wer erklärt mir wie das einzubinden ist?)

:-)


Kommentar von Michael (Michael) - Mittwoch, 22. Dezember 2010 - 08:42

Die 4 Sekunden Verzögerung ist für den Fall also zu lang? Man könnte man die Verzögerung variabel machen, was würdet ihr davon halten? Allerdings müsste man dann die Einstellungs-Optionen neu anordnen, dass das alles passt. Müsste mal schauen, wie man das hinbekommt. Ist ja jetzt schon recht voll. Oder man macht die Einstellung versteckt, dass sie aus der INI gelesen wird, wenn sie da ist, aber nur manuell in der INI zu ändern ist?

Kommentar von Rico Niemand (Ricolein) - Dienstag, 28. Dezember 2010 - 12:33


die 4 Sekunden sind manchmal nervig. Und manchmal wiederum zu kurz wenn ich (bei SAP oder anderen lahmen Proggies) in irgendwelche tief verschachtelten Menüs klicken will. Ich hab zwar keine Ahnung von Autohotkey, aber das Script konnte ich anpassen. die Zeit ist jetzt von 0-30 sec variabel einstellbar. Bei der Einstellung 1 sec gibt es das Problem nicht mehr und der Screenshot ist sauber. Es sind nur wenig Zeilen die geändert wurden. Bei mir läuft es
ich hab dir das Skript mal zum Review geschickt. Wenn es so OK ist kannst du das vielleicht gleich so offiziell

Kommentar von Rico Niemand (Ricolein) - Montag, 28. März 2011 - 11:19


geänderte Script läuft seit einigen Monaten fehlerfrei bei mehreren Usern und auf verschiedenen Rechnern. Leider blieben PMs an die Zuständigen hier komplett ohne Antwort. Wem darf ich das Skript schicken damit es den Weg an die Allgemeinheit findet? Ich stufe es inzwischen als Fehlerfrei

Kommentar von Michael (Michael) - Montag, 28. März 2011 - 12:20


mal möchte ich um Entschuldigung für die Verzögerung auf meiner Seite bitten. Ich hatte mir das Script bereits angeschaut, konnte es aber nicht direkt übernehmen, da es in der Entwicklerversion schon einige Änderungen gegeben hatte, die eine einfache Zusammenführung nicht erlaubten. Ich werde nun so schnell wie möglich versuchen beide Versionen zu kombinieren und in einer neuen Entwicklerversion zur Verfügung zu

Kommentar von Michael (Michael) - Donnerstag, 31. März 2011 - 09:58


langer Verzögerung nun endlich die nächste Entwicklerversion in der die Änderungen integriert sind. Ich hoffe damit funktioniert alles wie

Lade...