EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#417 - DriveIcons Probleme

Gehört zu Projekt: ac'tivAid
Angelegt Anonymer Reporter - Montag, 31. Juli 2006 - 15:40
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → DriveIcons
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP2
Schweregrad Niedrig
Priorität Normal
Betrifft Version 1.1.3
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

1) Nach dem Update von 1.1.2 auf 1.1.3 hab ich DriveIcons wieder aktiviert. Bei der Auswahl “Folgende Laufwerke berücksichtigen” gab es vier Einträge. Der erste begann mit “ABCDE”. Dieser war auch selektiert und führt nach der Aktivierung zu einer falschen Anzeige, da es kein Laufwerk “B” in meinem Rechner gibt. Daraufhin habe ich den Eintrag “CDE... alle Laufwerke” ausgewählt. Das Icon “A” wurde erfolgreich entfernt, doch das Icon “B” musste ich per Hand entfernen. Inzwischen ist der Eintrag “ABCDE...” in der Auswahlliste nicht mehr vorhanden.

2) Das Entfernen von Icons funktioniert auch nicht beim Wechsel von “alle Laufwerke” auf “ohne Netzlaufwerke”.

3) Das Ändern von “Laufwerksbuchstabe vor dem Mediennamen” führt zu doppelten Icons (mit unterschiedlichen Namen).

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Donnerstag, 12. Oktober 2006 - 12:25
Grund für Schließung:  korrigiert
Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 03. August 2006 - 12:55

Besteht das Problem mit der aktuellen Beta-Version weiterhin?

Sie können in der Konfiguration unter activAid die automatische Aktualisierung so konfigurieren, dass sie auch Beta-Versionen berücksichtigt.

Kommentar von Mathias Kalb (Mathias) - Freitag, 04. August 2006 - 09:08

Die Probleme existieren auch in der aktuellen Beta. Sollte sich denn etwas geändert haben?

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 24. August 2006 - 15:45

Die Probleme existieren auch noch in der aktuellen Version (1.1.4.4 beta).

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 24. August 2006 - 15:50

Eigentlich ja. :-(

Dass mit AB und lag am Updateskript und es ist mittlerweile behoben, allerdings nicht mehr nachträglich.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 24. August 2006 - 16:01

Bitte hänge hier mal deine ac’tivAid.ini an. Ich kann das nicht nachvollziehen. DriveIcons löscht eigentlich alle Verknüpfungen, wenn man OK oder Übernehmen klickt und legt dann neue an.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 24. August 2006 - 16:03

Als Workaround für die Probleme 2) und 3) kann man zuerst DriveIcons deaktivieren, dann “Übernehmen” drücken, dann die Änderungen vornehmen und danach wieder DriveIcons aktivieren. Lässt sich das Deaktivieren/Aktivieren nicht im Skript bei Änderungen automatisch druchführen?

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 24. August 2006 - 16:08

Hier also die INI-Datei.

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 25. August 2006 - 09:26

Ich kann das mit der INI-Datei auch nicht nachvollziehen. Übernehmen/OK löscht alle Verknüpfung (verschwinden vom Desktop) und baut sie dann neu auf, so wie es sein soll. Bitte hänge hier doch mal dein komplettes ac’tivAid-Verzeichnis an.

Kommentar von Mathias Kalb (Mathias) - Freitag, 25. August 2006 - 10:02

Ich habe gerade ac’tivAid deinstalliert und die Version 1.1.4 neu installiert. Danach habe ich die aktuelle Beta (1.1.4.4 beta) installiert. Das Verhalten ist leider genauso. Bei Übernehmen/OK werden alte Verknüpfungen nicht gelöscht. Nur wenn ich DriveIcons deaktiviere, werden alle angelegten (also auch doppelt angelegte) gelöscht. Irgendein Unterschied muss es zwischen diesen beiden Funktionen geben.

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 25. August 2006 - 10:45

Anbei mal eine Debug-Version von DriveIcons. Diese zeichnet im Hintergrund alle möglichen Tätigkeiten in die Zwischenablage auf. Bitte schicke mir den Inhalt der Zwischenablage mal zu ahk ÄT rumborak _ de.

Darauf achten, dass du nicht zwischendruch mal Strg+C drückst. Die Debugfunktion schaltest du aus, indem du di_Debug im der Datei auf 0 setzt. Änderungen erfordern ein Neuladen.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 11. Oktober 2006 - 09:17

Läuft jetzt eigentlich alles?

Kommentar von Mathias Kalb (Mathias) - Mittwoch, 11. Oktober 2006 - 09:42

Das Verhalten in der Version 1.1.5.37 beta ist noch genauso. Aber da das Problem nur während der Konfiguration auftritt, ist es nicht so wichtig. Ich habe im Moment DriveIcons sogar deaktiviert, da ich Probleme bei einem Spiel bekam. Das Spiel läuft im Fullscreen und reduziert die Auflösung auf 800×600. Die DriveIcons hatte ich rechts (MacOS) angeordnet. Nach dem Spiel waren die DriveIcons an einer neuen Position und wurden sofort automatisch wieder an die alte Position zurückgesetzt. Leider hatten sie dabei andere Icons auf dem Desktop verschoben die dann natürlich nicht automatisch an die alte Position zurückgesetzt wurden. D.h. nach jedem Spiel konnte ich meine Icons wieder sortieren.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 11. Oktober 2006 - 12:12

Das mit den verschobenen Icons lässt sich nur mit externen Tools (Restore Desktop oder Desktop Restore) verhindern. Noch gibt es keine Erweiterung zur Verwaltung der Icons.

Aber nochmal zum Problem. Beim Drücken von OK/Übernehmen werden die Icons nicht kurz gelöscht und wieder neu angelegt? Bitte schicke mir mal (oder hänge es hier an) ein ZIP von deinem ac’tivAid-Verzeichnis.

Kommentar von Mathias Kalb (Mathias) - Mittwoch, 11. Oktober 2006 - 12:55

Ja, beim Drücken von OK/Übernehmen werden die Icons bei Änderungen nicht gelöscht, sodass danach die Icons doppelt vorhanden sind. Ich schick dir das Verzeichnis als ZIP-Datei.

Zu meinem anderen Problem: Ich habe die anderen Icons so angeordnet, dass es kein Problem gibt wenn Spiele die Auflösung auf 800×600 heruntersetzen. Erst die Neupositionierung der DriveIcons (irgendwann nach 1.1.4 eingeführt) hat zu Problemen geführt, da diese die anderen Icons verschieben. Könnte diese Neupositionierung der DriveIcons optional sein?

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 08:12

So, ich habe mir deine Konfiguration angeschaut. Erstmal war DriveIcons deaktiviert. Ist das korrekt?

Allerdings kann ich das Problem nicht nachvollziehen. Folgendes habe ich gemacht. - DriveIcons aktiviert - Übernehmen geklickt → Icons erscheinen nach kurzer Zeit rechts auf dem Desktop - ein paar Icons auf dem Desktop verschoben - Die Option “Platz für CD/DVD-Laufwerke reservieren” zweimal angeklickt, damit die Übernehmen-Schaltfläche aktiv wird - Übernehmen geklickt - Nach einiger Zeit wurde die Icons korrekt neu aufgebaut und verschoben, also keine doppelten Icons.

Mach doch mal einen Screenshot, wenn du die doppelten Icons hast.

Zu der Auflösungsgeschichte: Wenn du Windows so konfiguriert hast, dass die Icons automatisch ausgerichtet werden kommen sich die Neupositionierung von Windows und DriveIcons etwas in die Quere. Selbst wenn das jetzt in DriveIcons optional wäre, würde Windows alles durcheinanderwürfeln. Alternativ könntest du die Icons normal, also nicht wie unter Mac OS anordnen lassen.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 08:36

Wie oben beschrieben, habe ich DriveIcons zur Zeit deaktiviert. Das ist also korrekt.

Das Problem tritt auch nicht bei der Option “Platz für CD/DVD-Laufwerke reservieren” auf, sondern bei “Laufwerksbuchstabe vor dem Mediennamen” (siehe Original-Beitrag).

Ich habe ihnen mal Screenshots per Mail geschickt, dann wird das Problem hoffentlich besser deutlich.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 09:07

Oh Mann ... da stand ich wohl echt auf’m Schlauch. Jetzt kann ich’s nachvollziehen. Ich denke Beta 39 behebt das Problem.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 09:21

Ich habe es gleich getestet. Leider ist das Verhalten noch genauso.

Beim Wechsel von “alle Laufwerke” auf “ohne Netzlaufwerke” werden die Netzlaufwerke übrigens auch nicht gelöscht.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 09:42

Hmmm... was ist mit Beta 40

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 09:52

Leider immer noch die selben Probleme.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 10:04

D.h. du aktivierst “Laufwerksbuchstabe vor dem Mediennamen” und drückst Übernehmen und es erscheinen immer noch doppelte Icons? Das kann eigentlich nicht sein. Beende mal ac’tivAid, lösche alle übrigen Icons manuell und starte ac’tivAid neu.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 10:16

Ja, das Verhalten ist noch genauso wie bei den Screenshots die ich dir geschickt habe.

Die Icons brauchte ich übrigens nicht manuell löschen. Wenn ich DriveIcons deaktiviere löscht er alle Icons (auch wenn doppelte vorhanden sind). Dort funktioniert es also.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 10:48

Beta 41 die Nächste ...

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 10:58

Leider alles noch so wie vorher :-(

Vielleicht sollten wir den kleinen Bug einfach ignorieren.

Durch das Deaktivieren von DriveIcons kann man ja alle Icons löschen und dann stellt man die gewünschten Parameter ein und aktiviert DriveIcons. Solange man Änderungen nur im deaktivierten Zustand durchführt treten keine Probleme auf.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 11:07

Bitte schicke mir nochmal dein Verzeichnis zu.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 11:17

Okay, mach ich gleich.

Zur Info: Das Problem tritt auch auf wenn ich die Icons in der Schnellstartleiste anzeigen lasse.

Nochmal zu meinem Anordnungsproblem: Zitat von dir: “Zu der Auflösungsgeschichte: Wenn du Windows so konfiguriert hast, dass die Icons automatisch ausgerichtet werden kommen sich die Neupositionierung von Windows und DriveIcons etwas in die Quere. Selbst wenn das jetzt in DriveIcons optional wäre, würde Windows alles durcheinanderwürfeln. Alternativ könntest du die Icons normal, also nicht wie unter Mac OS anordnen lassen.”

Das automatische Anordnen von Icons auf dem Desktop ist bei mir deaktiviert.

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 11:54

Na, dann noch ein Versuch: Beta 42

Windows ordnet die Icons beim Auflösungswechsel immer neu an, wenn sie nicht drauf passen. DriveIcons könnte höchstens die eigenen Icons über andere legen, aber nicht andere verschieben.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 12:03

Ja, jetzt funktioniert es :-)

Was hast du eigentlich in den Betas (40, 41, 42) geändert und was war die Ursache/Lösung?

Trat das Problem bei dir eigentlich nicht auf?

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 12. Oktober 2006 - 12:07

Hi, das Problem trat nur auf, wenn ich deine Version genommen habe und auf “ohne Netzlaufwerke” umgestellt habe. Anderes Sachen funktionierten.

Das Skript hat nach dem Löschen der Icons einfach zu schnell weitergearbeitet. Ein Pause von 300ms war des Problems Lösung. Warum genau das so ist, verstehe ich allerdings auch nicht. Aber irgendwann gelangt man an den Punkt, wo einem der Grund egal ist. ;-)

Vielen Dank für deine Ausdauer und Mithilfe.

Kommentar von Mathias Kalb (Mathias) - Donnerstag, 12. Oktober 2006 - 12:14

Dann kannst du jetzt endlich diese Aufgabe schließen. Schön.

Dir auch vielen Dank für dieses praktische Tool und weiterhin viel Erfolg und Spaß bei der Entwicklung. Ich bin schon auf die nächsten Versionen gespannt.

Lade...