EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#487 - STRG+C mit ping in CMD aus UserHotkeys

Gehört zu Projekt: ac'tivAid
Angelegt Jürgen Binder (bj05) - Mittwoch, 06. September 2006 - 07:38
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → UserHotkeys
Status Geschlossen
Zuständig Admin (super)
Betriebssystem Windows XP SP2
Schweregrad Niedrig
Priorität Normal
Betrifft Version 1.1.4
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

Ich hab eine Tastenkombination in UserHotkeys (Strg+Alt+D) zum Öffnen einer cmd.exe. Interessanterweise kann ich in dieser CMD einen ping nicht mit Strg-C abbrechen. Sonnst (zb. nslookup ,...) funktioniert Strg+C und auch beim ping, wenn ich die CMD “normal” starte.

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Mittwoch, 11. Oktober 2006 - 09:19
Grund für Schließung:  korrigiert
Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 06. September 2006 - 08:26

Kann ich nicht nachvollziehen. Bitte mal einzeln die Erweiterungen MultiClipboard und PastePlain deaktivieren.

Kommentar von Jürgen Binder (bj05) - Mittwoch, 06. September 2006 - 08:33

Hab ich gemacht, hab auch das Ac’tivAid deaktiviert - geht trotzdem nicht. Hab vergessen: ich verwend dir portable-Version ...

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 06. September 2006 - 09:18

Änderen Sie mal testweise das Kürzel auf Shift+Alt+D. Ansonsten: Was passiert, wenn sie CMD starten und dann ac’tivAid beenden?

Kommentar von Jürgen Binder (bj05) - Mittwoch, 06. September 2006 - 09:36

mit Shift+Alt+D funktionierts. Komisch dabei ist, dass es scheinbar nur den ping betrifft. Wenn ich nach Strg-Alt-D das ac’tivAid beendete, gings trotzdem nicht! Jetzt hab ich wieder Strg+Alt+D eingestellt und siehe da, es funktioniert auf meinem PC. Hab dann das gleiche auf einem anderen PC probiert (seperate Installation), dort gehts nicht!

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 06. September 2006 - 09:45

Ich vermute da hängt irgendwie die Strg-Taste fest. Man könnte vor dem Strg+C mal ein Win+Shift+# machen. Würde mich mal interessieren, ob das mit der aktuellen Beta nicht mehr auftritt.

Kommentar von Jürgen Binder (bj05) - Mittwoch, 06. September 2006 - 09:48

Die Problembehebung hilft nix. Ich werd mal bei Gelegenheit die beta probieren ... Auf meinem PC funktionierts ja jetzt witzigerweise ;-) Danke für die Bemühungen!

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 00:31

Läuft jetzt alles?

Kommentar von Jürgen Binder (bj05) - Mittwoch, 27. September 2006 - 06:19

Ja, Danke. Habs jetzt auf 2 PCs mit der 1.1.5.15 beta portable probiert und es geht. Allerdings hab ich mit die “alte” umgebaut, dass die Settings im Home-Verzeichnis des Users am Server gespeichert werden. Da ich grad keine Zeit hab, das wieder zu machen, werd ich mich daran gewöhnen ...

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 07:08

Wie umgebaut? Es reicht doch eine Verknüpfung zu ac’tivAid im Home-Verzeichnis abzulegen oder in der Autostart-Verknüpfung den Arbeitspfad auf das Home-Verzeichins zu setzen.

Kommentar von Jürgen Binder (bj05) - Mittwoch, 27. September 2006 - 08:09

Das hab ich probiert - weil readme gelesen ;-) - , funktioniert aber leider nicht.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 08:13

Was funktioniert nicht? Was passiert denn?

Kommentar von Jürgen Binder (bj05) - Mittwoch, 27. September 2006 - 08:32

ac’tivAid Programm-Verzeichnis ist lokal, Settings auf H:\settings, Verknüpfung mit Arbeitsverzeichnis auf h:\ oder h:\settings. Die Einstellungen werden weder von H:\settings gelesen, noch gespeichert (Hotstrings.ini, ac’tivAid.ini) Habs grad mit der letzten Beta probiert, es wird alles im Programm-Verzeichnis unter Settings gespeichert.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 09:00

Sie haben Recht. Die Autostart-Verknüpfung wird auf das Benutzerverzeichnis verändert. Beta 17 behält nun das frei gewählte Verzeichnis bei. Aber generell gilt, dass ac’tivAid dann auch über die Verknüpfung gestarte werden muss.

Kommentar von Jürgen Binder (bj05) - Mittwoch, 27. September 2006 - 09:07

Danke! Starten nur mit Verknüpfung ist klar! (bzw. per Script mit Verzeichniswechsel vor Start ...)

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 09:10

Und, klappt’s jetzt?

Kommentar von Jürgen Binder (bj05) - Mittwoch, 27. September 2006 - 10:03

Ja, funktioniert. Man muss aber “...\AutoHotkey.exe ...\ac’tivAid.ahk” starten. Die “Portable ac’tivAid.exe” übernimmt das Arbeitsverzeichnis nicht - macht aber nix.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 11:34

Klappt’s hiermit besser?

Kommentar von Jürgen Binder (bj05) - Mittwoch, 27. September 2006 - 14:27

Damit funktionierts! Mir ist allerdings aufgefallen, dass die extensions auch im Arbeitsverzeichniss liegen müssen - ist das gewünscht? Dadurch müsste man bei einem Update allen Usern die neuen extensions verpassen ...

Kommentar von Admin (super) - Mittwoch, 27. September 2006 - 14:39

Die einzelnen Benutzer müssen die Erweiterungen nur installieren, dann werden die Pfade richtig gesetzt.

Lade...