EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#519 - Verknüpfungen zu nicht vorhandenen Netzwerkordnern bremsen AppLauncher extrem aus

Gehört zu Projekt: ac'tivAid
Angelegt André Berg (Deltaman) - Dienstag, 19. September 2006 - 12:07
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → AppLauncher
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Alle
Schweregrad Mittel
Priorität Normal
Betrifft Version 1.1.4
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

Hallo!

Im Zuge des Eintrages  FS#430  (”AppLauncher indiziert keine reinen Ordner-Verknüpfungen”) kann AppLauncher seit v1.1.3 ja nun auch Ordnerverknüpfungen miteinbeziehen, wenn man in den Optionen das entsprechende Häkchen setzt. Funktioniert auch prima, nur unter folgenden Bedingungen wird der Start von AppLauncher nun extrem langsam, so dass man esdann kaum benutzen kann. Nach langem Experimentieren, hier die Kombination an Bedingungen, die für dieses Verhlaten zutreffen müssen:

1. Man hat das Häkchen “Ordnerverknüpfungen einbeziehen” gesetzt.

2. Man hat in den “weiteren Optionen” unter “Verzeichnisse, die immer dynamisch indiziert werden” ein oder mehrere Verzeichniseinträge drin stehen.

3. In einem der Ordner, die in 2. angegeben sind, befindet sich eine Ordnerverknüpfung auf ein Netzlaufwerk, welches gerade nicht verfügbar ist.

Sobald 1., 2. und 3. zutreffen, verzögert sich der Start von AppLauncher nun jedes Mal extrem (statt ein paar Sekundenbruchteilen zum Erscheinen des Suchfensters, dauert der Start dann bis zu 30 Sekunden, während derer ac’tivAid auch sonst anderweitig nicht mehr reagiert).

Vermutlich versucht AppLauncher die Ordnerverknüpfungen nicht einfach nur zu indexieren, sondern folgt jeder einzelnen zu ihrem Ziel (Warum eigentlich? Zum Anzeigen eines etwaigig vorhandenen Icons?). Entweder sollte AppLauncher Ordnerverknüpfungen überhaupt nicht zum Ziel folgen oder sollte dieses zumindest bei denjenigen Ordnern sein lassen, die dynamisch jedes Mal durchsucht werden. Der nicht dynamische Indexer stört sich an nicht vorhandenden Netzverknüpfungen anscheinend nicht, zumindest verlangsamt das nicht den Start von AppLauncher.

Lässt sich da was machen? Ich würde ungern auch meine 1./2./3.-Kombination verzichten, benutze diese sogar extrem intensiv.

André

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Mittwoch, 11. Oktober 2006 - 09:12
Grund für Schließung:  korrigiert
Kommentar von André Berg (Deltaman) - Dienstag, 19. September 2006 - 12:08

Achso, dieses (blöde) Verhalten betrifft natürlich nicht nur Version 1.1.4, mit der das neue Feature “Ordnerverknüpfungen miteinbeziehen” Einzug gehalten hat, sondern ist in 1.1.5 natürlich auch noch vorhanden.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 20. September 2006 - 01:48

Können Sie mal ausprobieren, ob das Problem an den Icon-Einstellungen liegt? Ich kann es hier nicht reproduzieren.

Kommentar von André Berg (Deltaman) - Mittwoch, 20. September 2006 - 16:22

Hmmm, nein bei mir auch dann keine Änderung. Selbst wenn ich alle Häkchen unter “Infobereich” entferne und unter “Listeneinstellungen” das Häkchen bei “Icons in der Liste anzeigen” rausnheme, bleibt das Verhalten gleich.

Ich teste wie folgt:

1. Häkchen (siehe ganz oben) ist gesetzt (alle anderen Häkchen haben keinen Einfluss, soweit ich das beurteilen kann)

2. Unter “Verzeichnisse, die immer dynamisch indiziert werden” wird nur folgender Ordner aufgeführt: “C:\Dokumente und Einstellungen\aberg\Eigene Dateien\Meine Spezialordner\Verknüpfungen für AppLauncher”

3. Kopiere ich beispielsweise die “Testverknüpfung.lnk” aus dem RAR-Archiv anbei in den Ordner unter 2. tritt beim Starten von AppLauncher die besagte Verzögerung auf. Beim Weglöschen dieser Datei aus 2. ist sofort wieder alles im Lot. Beim erneuten Hineinkopieren geht das gleiche Spielchen von vorne los.

Bei mir reproduzierbar, auch auf mehreren Rechnern. Bei dieser Testverknüpfung.lnk handelt es sich übrigens um eine “echte”, von mir lediglich umbenannte Verknüpfung zu einer Netzwerkquelle, die nur aus meinem Büro erreichbar ist.

André

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 21. September 2006 - 08:51

Danke für die ausführliche Darstellung. Jetzt kann ich das Problem nachvollziehen. Die Ursache liegt aber leider bei Windows. Sie verwenden keine Laufwerksbuchstaben, sondern einen direkten Netzwerkpfad. Windows meldet da leider erst nach erheblicher verzögerung, dass es die IP-Adresse nicht finden kann, was man ja schon bei einem Rechtsklick auf so eine Verknüpfung merkt. Der AppLauncher versucht zu erkennen, ob eine Verküpfung auf einen Ordner verweist und genau da wartet AutoHotkey ewig, bis Windows eine Meldung zurückgibt. Ich habe in Beta 8 nun den Fall übergangen, dass bei Verknüpfungszielen ohne ?:\ ein Ordner nur noch vermutet (keine Dateiendung) und nicht mehr ermittelt wird.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 27. September 2006 - 00:16

Klappt das jetzt?

Kommentar von david s (taffit) - Sonntag, 06. November 2011 - 15:55

Da ich auch in der aktuellen Developer-Version 40 immer noch dasselbe Problem hatte (und darum neben dem wunderbaren ac'tivAid noch nDroid als Programmstarter laufen lassen musste): sobald man die Option "Pfad-Variablen im Index verwenden" AUSschaltet, können auch die Optionen mit den Ordnern angehakt bleiben. Vielleicht hat es ja damit etwas zu tun.

Lade...