EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#567 - Probleme mit Eject & USB Devices

Gehört zu Projekt: ac'tivAid
Angelegt Anonymer Reporter - Freitag, 06. Oktober 2006 - 11:30
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → Eject
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Alle
Schweregrad Mittel
Priorität Normal
Betrifft Version 1.1.5.44 beta
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

Über Gerätenamen zuweisen: 1) Externe HD → USB\VID_1955&PID_1021\DEF10911 ‘USB Mass Storage Device’ [REMOVEABLE] Fehlermeldung: “Das Laufwerk oder Medium kann nicht mit DevEject.exe ausgeworfen werden. Entweder wird das Laufwerk nicht unterstützt oder Dateien/Verzeichnisse sind geöffnet! (Unknown) -EjectId:” ...” "

2) Externe HD → USBSTOR\DISK&VEN_SAMSUNG&PROD_SP1604N&REV_\DEF10911&0 ‘SAMSUNG SP1604N USB Device’ Fehlermeldung: siehe oben

3) Externe HD → -EjectDrive:U: Fehlermeldung: “Das Laufwerk oder Medium kann nicht mit DevEject.exe ausgeworfen werden. Entweder wird das Laufwerk nicht unterstützt oder Dateien/Verzeichnisse sind geöffnet! (Unknown) -EjectId:”-EjectDrive:U:””

4) als Laufwerk direkt U: eingegeben → funktioniert, jedoch verschwindet nach Klick auf übernehmen hinter Laufwerk: der Wert U: in der Auswahlbox (was aber nicht weiter stört - höchstens, wenn man sehr viele Geräte verwaltet und dann keinen Überblick hat)

5) habe gerade festgestellt, dass 1) und 2) falsch ist - da ist die Hilfe nicht eindeutig richtig wäre Externe HD → U: Fehlermeldung: “Das Laufwerk oder Medium kann nicht mit DevEject.exe ausgeworfen werden. Entweder wird das Laufwerk nicht unterstützt oder Dateien/Verzeichnisse sind geöffnet! (Unknown) -EjectDrive:U:”

Es klappt also nur 4) (bei mir)

PS: Sorry für den neuen Thread, jedoch konnte ich mich nicht anmelde - es wurde kein Bestätigungscode versendet Eiegntlich hätte ich auf Aufgabe 562 geantwortet

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Dienstag, 16. Januar 2007 - 05:44
Grund für Schließung:  implementiert
Kommentar von Wolfgang Reszel (Tekl) - Montag, 09. Oktober 2006 - 08:34

3) Wo gibst du denn “EjectDrive:U:” ein? Das solltest du eigentlich nirgendwo in ac’tivAid angeben.

4) Wo gibt du direkt U: ein? In Gerätenamen zuweisen oder direkt bei Eject? Wenn du das direkt bei Eject machst, tippst du da mit Doppelpunkt? Warum? Kannst du U nicht direkt auswählen, also ist das nicht mit in der Liste?

5) Verstehe nicht ganz was du meinst.

Kommentar von Axel (Axel83) - Freitag, 20. Oktober 2006 - 13:24

3) in Gerätenamen zuweisen → zugewiesenes Gerät - an der Fehlermeldung sieht man ja auch, dass es flasch war...

4) Ich hatte es direkt in Eject eingegeben und irrtümlich angenommen, dass es klappt, weil keine Fehlermeldung kommt. Es funktioniert jedoch nicht. U kann ich nicht direkt auswählen.

Ich habe es bisher noch nicht geschafft die externe Festplatte auszuwerfen :-( In Gerätenamen zuweisen habe ich “Externe HD → U:”, was ja richtig sein sollte. Jeoch kommt die Fehlermeldung: Fehlermeldung: “Das Laufwerk oder Medium kann nicht mit DevEject.exe ausgeworfen werden. Entweder wird das Laufwerk nicht unterstützt oder Dateien/Verzeichnisse sind geöffnet! (Unknown) -EjectDrive:U:”

Auch mit der 1.1.6 hatte ich noch keinen Erfolg.

Ich denke das Problem wird bei DevEject liegen: deveject.exe -EjectDrive:U: bringt Invalid drive specification ‘U:’ (auch mit U, U:\ probiert)

Gibts es da noch Hoffnung?

Kommentar von Wolfgang Reszel (Tekl) - Freitag, 20. Oktober 2006 - 14:13

DevEject kann meines wissens nur Wechseldatenträge auswerfen, ich weiß nicht wie eine externe Festplatte am System angemeldet ist. Evtl. ist das Tool RemoveDrive hilfreich, welches du derzeit über UserHotkeys ansprechen müsstest. Falls es damit klappt, werde ich eine Unterstützung dafür in Eject einbauen.

Infos und Download unter: http://www.uwe-sieber.de/usbstick.html

Kommentar von Axel (Axel83) - Dienstag, 31. Oktober 2006 - 22:43

Die externe Festplatte wird als lokaler Datenträger angemeldet und das scheint also tatsächlich der Grund zu sein, warum es die Probleme mit DevEject gibt. Uwe Siebers RemoveDrive funktioniert und ich würde mich freuen, wenn es integriert werden kann. (Probleme verursachte noch Copernic Desktop Search, welches die Festplatte nicht frei gab... Nützlich wäre in solchen Fällen ein Hinweis in der Hilfe auf den Tip mit Sysinternals ProcessExplorer > Search > X:)

Kommentar von Wolfgang Reszel (Tekl) - Dienstag, 07. November 2006 - 14:23

RemoveDrive wird nun unterstützt. (Siehe Hilfe)

Kommentar von Axel (Axel83) - Dienstag, 21. November 2006 - 18:26

Ich benutze es nun schon länger und habe keine Problem.

Vielen Dank. :o)

Lade...