EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#624 - AppLauncher bricht Indizierung bei bestimmtem EXE File ab

Gehört zu Projekt: ac'tivAid
Angelegt Andreas Koch (koksman) - Mittwoch, 25. Oktober 2006 - 13:15
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → AppLauncher
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP2
Schweregrad Niedrig
Priorität Normal
Betrifft Version 1.1.6.48 beta
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

Hi, die Erweiterung AppLauncher bereitet Probleme beim Indizieren eines Applikationsverzeichnises. Aus unerfindlichen Gründen bricht die Indizierung mittendrin bei den Dateien en01eas.exe / ez01pb.exe ab. Die erste EXE landet noch im Index, die zweite und alle fortfolgenden nicht mehr. Setze ich den Files einen beliebigen Präfix wie z.B. my... voran, funktioniert die Indizierung tadellos. Woran liegt das? Ist “ez01pb” eine reservierte Zeichenkette, die den Abbruch verursacht? Gruss Andreas

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Donnerstag, 16. November 2006 - 09:52
Grund für Schließung:  korrigiert
Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 25. Oktober 2006 - 13:35

Vermutlich enthält der Dateiname Unicode-Zeichen die wie normale Zeichen aussehen. AutoHotkey kommt derzeit leider nicht damit zurecht. Benenne die Datei doch mal von Hand in “ez01pb.exe” um. Es gibt auch Unicode-Zeichen die man kaum oder gar nicht sieht. So eins könnte auch im Namen stecken.

Kommentar von Andreas Koch (koksman) - Mittwoch, 25. Oktober 2006 - 14:02

Problem behoben :) Es war kein Unicode Zeichen sondern die Existenz eines AsciiFiles, das ohne Extension mit der Filebezeichnung “error” dort herumstand. Aus alphabetischer Sicht liegt das Teil bei der Abarbeitung des Verzeichnisses genau zwischen den oben genannten EXE files. Das hat dann schliesslich die Indexierung aus der Bahn geworfen. Jetzt funzt es. Super! :)

Kommentar von Andreas Koch (koksman) - Mittwoch, 25. Oktober 2006 - 14:04

Soll heissen: ich hab das AsciiFile namens “error” gelöscht ...

Kommentar von Karsten Paulini (kapa) - Mittwoch, 08. November 2006 - 10:13

Ich finde dieses Problem sehr, sehr lästig. Bei mir war es zunächst eine Datei “Lizenz”. Nach umbenennen in lizenz.txt (also mit Extension) bin ich aber wieder nur ein paar Verzeichnisse weitergekommen. Herauszufinden, wo in der nachfolgenden Verzeichnis-Hierarchie irgendwo weitere Dateien ohne Extension existieren, ist recht mühselig. Außerdem darf man die Dateien u. U. nicht einfach umbenennen. Je nachdem, wo sich die erste solche Datei befindet, kann man den AppLauncher möglicherweise gar nicht vernünftig einsetzen. Ich würde daher den Schweregrad sogar etwas hochsetzen.

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 08. November 2006 - 11:25

Ich kann das Problem nicht nachvollziehen. Ich habe einige Dateien ohne Erweiterung erstellt. Die bereiten keine Probleme. Wie ist bei euch der Applauncher denn konfiguriert?

Kommentar von Karsten Paulini (kapa) - Mittwoch, 08. November 2006 - 12:57

Ich kann den Effekt durch Hinzufügen/Löschen der Extension der genannten Datei beliebig reproduzieren.

Ich habe jetzt mal folgendes gemacht, um das Problem nachzuvollziehen: In c:\Programme\ac’tivAid\development habe ich einfach eine leere Datei “Licence” angelegt. Alphabetisch liegt sie genau zwischen den beiden standardmäßig vorhandenen ahk-Dateien. Die Indexierung bricht jetzt genau bei ihr ab und fährt mit dem nächsten Verzeichnis in c:\Programme (bei mir Microsoft Office) fort. Durch Ergänzen der Extension oder Löschen der Datei werden auch wieder die weiteren ahk-Dateien in development und extensions indexiert.

Ich hoffe das hilft Dir weiter!

Kommentar von Karsten Paulini (kapa) - Mittwoch, 08. November 2006 - 12:59

Ich verwende übrigens Version 1.1.6

Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 08. November 2006 - 13:26

Verstehe ich das jetzt richtig? ac’tivAid stürzt nicht ab, sondern es fehlt einfach ein Teil des Indexes? Mensch, dann habe ich die ganze Zeit nach falschen möglichen Ursachen gesucht ... Ich schau’s mir noch mal an.

Kommentar von Andreas Koch (koksman) - Mittwoch, 08. November 2006 - 14:01

Richtig. Ac’ivaid stürzt nicht ab, sondern die Indizierung im aktuellen Verzeichnis bricht beim Auffinden eines Files ohne Extension einfach ab und setzt im nächsten Verzeichnis fort. Das File kann beliebig heissen, darf aber keine Extension besitzen. Gleiches Verhalten wie bei kapa. Nutzen tue ich die aktuelle Beta 1.1.6.12

Kommentar von Wolfgang Reszel (Tekl) - Donnerstag, 09. November 2006 - 15:20

So, bitte mal Beta 13 testen, ich hoffe das war’s.

Kommentar von Andreas Koch (koksman) - Donnerstag, 09. November 2006 - 19:32

Yepp. Jetzt funktioniert es tadellos. Klasse! Besten Dank.

Kommentar von Karsten Paulini (kapa) - Freitag, 10. November 2006 - 20:23

Ja, jetzt klappt es. Wieviele Einträge die Indexierung bislang übersprungen hatte, sieht man daran, daß der Vorgang bei mir jetzt 3 bis 4 mal länger dauert. Super!

Lade...