EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#778 - Ahk2Exe Error - Error adding FileInstall file: settings\Hotstrings.ini

Gehört zu Projekt: ac'tivAid
Angelegt Klaus Walte (Klaus) - Dienstag, 06. Februar 2007 - 15:06
Zuletzt bearbeitet von Wolfgang Reszel (Tekl) - Montag, 12. März 2007 - 15:29
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → PackAndGo
Status Geschlossen
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP2
Schweregrad Mittel
Priorität Normal
Betrifft Version 1.1.7
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 100%
Stimmen 0
Versteckt Nein

Beschreibung

Bei Durchführung von Pack & Go trat die Fehlermeldung auf, die im Anhang zu sehen ist. Nichtsdestotrotz wurde “ac’tivAid.exe” verschoben und die Kompilierung als beendet gemeldet. Ich habe noch nicht getestet, ob die verschobene .exe verwendungsfähig ist.

Diese Aufgabe ist abhängig von

Geschlossen  Wolfgang Reszel (Tekl)
Montag, 12. März 2007 - 15:29
Grund für Schließung:  korrigiert
Kommentar von Wolfgang Reszel (Tekl) - Mittwoch, 07. Februar 2007 - 05:40

Existiert die Datei bei dir denn?

Kommentar von Klaus Walte (Klaus) - Samstag, 10. Februar 2007 - 18:13

Nein, ich finde nur “..\settings\Hotstrings.ini.bak” und “...\settings\Hotstrings.ini.disabled”. Es mag also sein, dass die Aktion ordnungsgemäß durchgeführt wurde. Nun wird jedoch ein “Error” gemeldet, so dass ich als vergleichsweise “dummer” Benutzer verunsichert bin, ob die fragliche Aktion geklappt hat oder nicht. Aus einem “Error” schließe ich: sie hat nicht geklappt. Falls es also unter gewissen Umständen “normal” ist, dass “...\settings\Hotstrings.ini” fehlt - womöglich aufgrund der Nichtbenutzung von Hotstrings -, dann sollte die Software feststellen können, dass das Nichtvorhandensein von “...\settings\Hotstrings.ini” aufgrund der Konfiguration von ac’tivAid keinen Fehler darstellt, und eine Fehlermeldung sollte unterbleiben. Eine andere Möglichkeit, das Problem zu beheben, wäre die Dokumentation dieses Verhaltens bei PackAndGo, d. h. dem Benutzer zu sagen, dass solche Fehlermeldungen für ein erfolgreiches PackAndGo unbeachtlich sind.

Kommentar von Wolfgang Reszel (Tekl) - Samstag, 10. Februar 2007 - 18:39

Achso, Hotstrings war deaktiviert aber weiterhin deinstalliert. Der Fehler ist nicht schlimm. Nicht verwendete Erweiterungen solltest aber generell deinstallieren, ein deaktiviertes HotStrings hat eh keinen Sinn in einer Exe-Datei, da man es da nicht wieder aktivieren kann. In Beta 8 habe ich einen Workaround für den Fehler eingebaut.

Kommentar von Klaus Walte (Klaus) - Samstag, 10. Februar 2007 - 19:20

Heißt das, ich sollte bei HotStrings nicht nur das Häkchen oben rausnehmen, sondern auch im Menü “Erweiterungen” den Punkt “HotStrings aus dem Konfigurationsfenster entfernen” anwählen? Hab’ ich bisher nicht beachtet. Guter Tipp. Vielleicht hören dann auch die immer mal wieder auftretenden AutoHotkey-Abstürze beim Autostart von ac’tivAid auf. Gilt das auch für alles andere, was ich nur durch Häkchenwegnehmen deaktiviert habe? Wahrscheinlich wird’s dann aber nicht mehr angezeigt, höchstens noch bei “Erweiterung”, “Entfernte Erweiterungen wieder herstellen ...”. Eigentlich möchte ich aber auch die deaktivierten Erweiterungen noch im Fenster sehen können, denn bei der überbordenden Fülle von ac’tivAid vergesse ich manchmal, was die eine oder andere Erweiterung bedeutete, und deshalb gucke ich immer mal wieder über den Fragezeichen-Knopf nach, ob ich eine Erweiterung doch noch wieder aktivieren sollte. Dieses Nachgucken geht dann aber wohl nicht mehr bei deinstallierten Erweiterungen, oder?

Kommentar von Klaus Walte (Klaus) - Samstag, 10. Februar 2007 - 19:25

Ach, ich sehe jetzt, unter “Erweiterungen” in der Liste links kann man ja auch die Hilfetexte für alle Erweiterungen sehen, egal ob installiert oder deinstalliert.

Kommentar von Klaus Walte (Klaus) - Samstag, 10. Februar 2007 - 19:27

Offenbar gibt es die drei Möglichkeiten: Erweiterungen deaktivieren (Häkchen wegnehmen), Erweiterungen entfernen (Menü Erweiterung) und Erweiterungen deinstallieren. Korrekt?

Kommentar von Wolfgang Reszel (Tekl) - Sonntag, 11. Februar 2007 - 12:19

Nein, es gibt nur eine Möglichkeit Erweiterungen zu entfernen und das ist die Erweiterungsverwaltung links in der Liste. Durch Deaktivieren (mit dem Haken) wird eine Erweiterung abgeschaltet, sie befindet sich aber weiterhin im Speicher. Das Entfernen aus der Konfiguration versteckt quasi eine Erweiterung, sie behält aber ihre Funktion. Das kann man dazu benutzen, um das Konfigurationsfenster etwas übersichtlicher zu gestalten. Einige Erweiterungen müssen nämlich nur einmal konfiguriert werden.

Lade...