EN NL

ac'tivAid

Leider muss an dieser Stelle mitgeteilt werden, dass Wolfgang Reszel seine Arbeit an ac'tivAid beendet hat. Eine Entwicklerversion von ac'tivAid gibt es auf meiner Webseite. Gruß, Michael

Willkommen beim Bugtracker zu ac'tivAid. Ac'tivAid ist ein AutoHotkey-Skript, welches zuletzt in c't 12/08 ausführlich vorgestellt wurde.
Die letzte stabile Version finden Sie unter www.heise.de/ct/activaid.

Wenn Sie in der stabilen Version einen Fehler finden, testen Sie bitte erst die aktuelle Beta-Version, bevor Sie den Fehler melden!

Um evtl. schon hier behandelte und geschlossenen Themen mit der Suche zu finden, muss in der erweiterten Suche bei Status "Alle offenen Aufgaben" auf "Alle Status" umgestellt werden.

Letzte stabile Version bei Heise.de: 1.3.1

Letzte beta Version 1.3.2 beta1 : activaid_beta.exe | portable_activaid_beta.exe

Entwicklerversion von Michael

Änderungen, Liesmich/Hilfe, FAQ und Themen-Special (bei www.heise.de)

Digital Upgrade haben ein Video zu ac'tivAid 1.1.8.1 gedreht, wo ein paar Funktionen kurz angesprochen werden.

Aufgabenliste

FS#1530 - Applauncher Indezierung bringt Hotkey auf 100% CPU-Auslastung

Gehört zu Projekt: ac'tivAid
Angelegt Tom (Megunfant) - Samstag, 21. Juni 2008 - 16:26
Aufgabentyp Fehlerbericht
Kategorie Erweiterungen → AppLauncher
Status Zugeteilt
Zuständig Wolfgang Reszel (Tekl)
Betriebssystem Windows XP SP2
Schweregrad Hoch
Priorität Normal
Betrifft Version 1.3.1
Fällig in Version Unbestimmt
Fällig am Unbestimmt
Prozent erledigt 0%
Stimmen 0
Versteckt Nein

Beschreibung

Wenn ich Applauncher neu indezieren lassen möchte, dann friert mein PC kurz vor Schluss des Indezierungsvorgangs ein. Die CPU-Auslastung von Hotkey geht auf 100% hoch. Wenn ich den Prozess dann per Taskmanager beende, wird bei einem weiteren offenen Programm, z.B. dem Firefox, die CPU-Auslastung auf 100% geschraubt. Das geht beliebig lange so weiter. Fazit ist: Neustart des Systems notwendig, da nicht mehr lauffähig.

Dieses Problem trat zuerst bei version 1.1.8 auf. Ich hatte gehofft, dass ein Update auf Version 1.3.1 etwas nützen würde, dem war aber nicht so.

Ein Reinstall von Ac’tivAid und Hotkey brachte keinen Erfolg.

Diese Aufgabe ist abhängig von

Kommentar von Michael (Michael) - Montag, 23. Juni 2008 - 07:47

Vielen Dank für die Meldung. Es wurde schonmal von Andreas erwähnt ( FS#1157 ). Allerdings konnte es noch nicht auf anderen Rechnern reproduziert werden. Wahrscheinlich liegt es an irgendeiner Inkompatibilität (irgendein eigenartiger Link oder ähnliches). Läuft die Indexierung denn durch, wenn man bei "Verzeichnisse, die indexiert werden:" nur ein einziges Verzeichnis mit sehr wenigen Links (oder vielleicht sogar nur einem einzigen Link) indexieren lässt?

Kommentar von Andrusch (Andrusch) - Montag, 23. Juni 2008 - 08:05

Hallo Tom, ich will mal meine Erfahrungen zu dem Problem mit einfließen lassen um sie hier zu sammeln und vielleicht ergeben sich Parallelen zw. unseren Systemen...

  1. Hängt die Indexierung immer an der selben Stelle (bei mir waren es immer andere Stellen)?
  2. Hast du einen Virenscanner oder eine Firewall aktiv (ich verwende Kaspersky Internet Security 7.0.1.325)?

Zu Michaels Frage: Ja, wenige Links funktionieren.

Soweit ich das damals eingrenzen konnte schein es ein Problem mit der FileGetShortCut-AHK-Funktion zu sein !?!

Gruß, Andreas

PS: Bei mir half beim "Hängen" meistens Folgendes: AutoHotkey nicht abschießen, sondern nur "Abmelden" (dabei dann AutoHotkey abschießen) und gleich wieder anmelden. Das spart zumindest etwas Zeit...

Kommentar von Tom (Megunfant) - Montag, 23. Juni 2008 - 09:07

Hmm... Also ich habe jetzt nochmal die Indezierung durchlaufen lassen und nur die Ordner Desktop und Startmenü/Programme indezieren lassen. Dann ging es ohne Probleme. Lasse ich den Ordner Startmenü indezieren, hängt es allerdings.

Ein weitere Durchlauf führt aber dazu, dass die Indezierung abgeschlossen wird, sich ein anderes Programm, in diesem Fall der Firefox, mit 100% CPU-Auslastung aufgehängt hat. Der Fehler ist sehr merkwürdig

Kommentar von Andrusch (Andrusch) - Montag, 23. Juni 2008 - 09:29

So ein ähnliches Verhalten, dass Tom beobachtet hat, kann ich bestätigen. Wenn Autohotkey nach "Hängen" abgeschossen wird und daraufhin eine andere Anwendung, das Hängen "übernimmt", kann man ac'tivAid neustarten und dann geht die Indexierung problemlos durch!

Andererseits habe ich auch schon (nach Hinzufügen einzelner kleinerer Verzeichnisse) mehrfache ordnungsgemäße Durchläufe und dann wieder ein Hängen mit den gleichen Verzeichnissen.

Kommentar von Andrusch (Andrusch) - Donnerstag, 09. Juli 2009 - 18:13

So, nach über einem Jahr hier nun meine neusten Testberichte:

Das Problem tritt bei mir NICHT mehr
Versionen: 1.3.2 Nightly 13 und die "portable"-Version dazu.

Das Indexieren läuft bei mir jetzt sauber bis zum Ende und ich kann AppLauncher endlich verwenden!!!


sieht es bei dir aus? Kannst du mal mit der neusten Version testen?


du mal bitte einen Link zu der letzten Nightly-Version zur Verfügung stellen? Ich habe die Adresse wieder vergessen...

Kommentar von Andrusch (Andrusch) - Freitag, 10. Juli 2009 - 06:22

"Wer lesen kann ist klar im
Link zum inoffizellen "Nightly Build" steht natürlich hier im Bugtracker ganz oben rechts direkt unter den offiziellen Versionen.

Lade...